What's new

Reverse Tilt Mirror not returning all the way to normal position after putting it back in Drive

palehorse

Member
Joined
Jan 2, 2023
Messages
36
Reaction score
16
Location
NC
I have a 2023 Sierra 1500 AT4. My drivers-side mirror doesn't return all the way up to its normal position after tilting downward in reverse. It only returns about halfway up and I have to manually re-adjust it each time. The passenger side works as it should.

Anyone else ever have this problem?

(I've turned the feature off for the time being).
 
OP
P

palehorse

Member
Joined
Jan 2, 2023
Messages
36
Reaction score
16
Location
NC
OK, some kind soul on Reddit figured it out for me!

The mirror positions are actually tied to the seat programming. I reprogrammed the #1 preset with the mirrors and seat where I want them, and now the mirrors properly return to the correct position after I switch back from Reverse to Drive.

Problem solved! :cool:
 

sclemmer

New member
Joined
Sep 25, 2022
Messages
8
Reaction score
11
Location
Texas
OK, some kind soul on Reddit figured it out for me!

The mirror positions are actually tied to the seat programming. I reprogrammed the #1 preset with the mirrors and seat where I want them, and now the mirrors properly return to the correct position after I switch back from Reverse to Drive.

Problem solved! :cool:
Can you test this again and confirm this actually worked? I have them same problem you describe, I reprogrammed the preset but my mirrors still don’t return to where they should every time. I have to hold the #1 preset button for them to return to where they should. I’d say this happens 50% of the time.
 
OP
P

palehorse

Member
Joined
Jan 2, 2023
Messages
36
Reaction score
16
Location
NC
Can you test this again and confirm this actually worked? I have them same problem you describe, I reprogrammed the preset but my mirrors still don’t return to where they should every time. I have to hold the #1 preset button for them to return to where they should. I’d say this happens 50% of the time.
It seems to have worked with mine - at least so far. I tested it several times today and it has worked ever time since I reprogrammed the #1 preset.

I'll pay back here if it fails again.
 

sclemmer

New member
Joined
Sep 25, 2022
Messages
8
Reaction score
11
Location
Texas
It seems to have worked with mine - at least so far. I tested it several times today and it has worked ever time since I reprogrammed the #1 preset.

I'll pay back here if it fails again.
Thanks for the reply, I’ll reprogram again tomorrow and see if I have better luck.
 

phobby

Member
Joined
Dec 16, 2022
Messages
39
Reaction score
9
Location
sc
Thanks for the reply, I’ll reprogram again tomorrow and see if I have better luck.
You also have to make sure the setting is turned on in the dash for programming to return seat and mirrors. If it’s off- it will never matter what you program.
 

sclemmer

New member
Joined
Sep 25, 2022
Messages
8
Reaction score
11
Location
Texas
You also have to make sure the setting is turned on in the dash for programming to return seat and mirrors. If it’s off- it will never matter what you program.
It is, otherwise, I wouldn’t have had the issue to begin with. Seems to be working as it should now after I “re-programmed” it a few times.
 
Top