Pulsar LT

NoSmoke

New member
Joined
Apr 1, 2024
Messages
10
Reaction score
2
Any pictures of both connectors? Have you reached out to Edge to make sure it wasn’t a boxing error. I have a 2020 6.2 and installed the same model number without issue.
 

Also installed the same part number without issue on my '21 6.2. Is it just the male, just the female, or both that won't connect?
 

It’s both and I called the manufacturer. Put in the serial
Number and harness number and it should work. I just returned it. Will get another one and try that
 

Any pictures of both connectors? Have you reached out to Edge to make sure it wasn’t a boxing error. I have a 2020 6.2 and installed the same model number without issue.
That groove I’m pointing it is too far wide it won’t connect to the female end. And the white female part won’t slide down and clip on so I can press the red button.
 

Attachments

  • IMG_6075.jpeg
    IMG_6075.jpeg
    390.3 KB · Views: 21
  • IMG_6077.jpeg
    IMG_6077.jpeg
    177.6 KB · Views: 20
  • IMG_6076.jpeg
    IMG_6076.jpeg
    343.8 KB · Views: 21
I do remember there were some that were having some sort of issue with the vertical ribs causing fitment problems. I think they were just grinding them down.
Hopefully the replacement works out, the pulsar makes the truck so much better.
 

I know I was so happy to install it and turn off the DFM. I watched video after video, wondering if I got the wrong one. They all slide on with ease, mine won’t.
 

Any pictures of both connectors? Have you reached out to Edge to make sure it wasn’t a boxing error. I have a 2020 6.2 and installed the same model number without issue.
IMG_6080.jpeg
 

Attachments

  • IMG_6079.jpeg
    IMG_6079.jpeg
    182.9 KB · Views: 15
I called Edge, gave them the year make and model of my truck. Gave him the part number I received. He did some digging and asked for the pulsars serial number, came back as compatibles. Then checked the pulsars harness serial number. Said it matched up. Even gave him the vin number..it checks out too. Gonna return it, get a replacement, if that doesn’t fit, I’ll shave down the ribs like someone mentioned and make it fit..
 

I called Edge, gave them the year make and model of my truck. Gave him the part number I received. He did some digging and asked for the pulsars serial number, came back as compatibles. Then checked the pulsars harness serial number. Said it matched up. Even gave him the vin number..it checks out too. Gonna return it, get a replacement, if that doesn’t fit, I’ll shave down the ribs like someone mentioned and make it fit..
Then it should work. I was reading that without my glasses and thought you said 2024. Forget everything I said as it doesn’t apply to yours! Been a long day.
 

I have one of these I took off my 21' 6.2 before I traded it in. I just pulled it out of the box. It looks identical to yours. It was a nice smooth mechanism, but I seem to recall if it wasn't all the way open or down, it wouldn't fit together.

This is an awesome upgrade, worth every penny! I should sell this, it is just sitting around. I am trying to remember if another person can use it after I initially had it installed. Does anybody know off the top of their head?
 

I just remembered It also corrects the speedo to compensate for larger tires. I had the throttle response in the middle. It was insane at the max. Love this mod.
 

New Posts

Most reactions

Back
Top